Recursive dependencies

sort(tools::package_dependencies("ggstatsplot", recursive = TRUE)[[1]])
#>  [1] "BayesFactor"         "bayestestR"          "BWStest"            
#>  [4] "cachem"              "cli"                 "coda"               
#>  [7] "colorspace"          "contfrac"            "correlation"        
#> [10] "cpp11"               "crayon"              "datasets"           
#> [13] "deSolve"             "digest"              "dplyr"              
#> [16] "effectsize"          "ellipsis"            "elliptic"           
#> [19] "fansi"               "farver"              "fastmap"            
#> [22] "generics"            "ggcorrplot"          "ggplot2"            
#> [25] "ggrepel"             "ggsignif"            "glue"               
#> [28] "gmp"                 "graphics"            "grDevices"          
#> [31] "grid"                "gtable"              "gtools"             
#> [34] "hypergeo"            "insight"             "ipmisc"             
#> [37] "isoband"             "kSamples"            "labeling"           
#> [40] "lattice"             "lifecycle"           "magrittr"           
#> [43] "MASS"                "Matrix"              "MatrixModels"       
#> [46] "mc2d"                "memoise"             "methods"            
#> [49] "mgcv"                "multcompView"        "munsell"            
#> [52] "mvtnorm"             "nlme"                "pairwiseComparisons"
#> [55] "paletteer"           "parallel"            "parameters"         
#> [58] "patchwork"           "pbapply"             "performance"        
#> [61] "pillar"              "pkgconfig"           "plyr"               
#> [64] "PMCMRplus"           "prismatic"           "purrr"              
#> [67] "R6"                  "RColorBrewer"        "Rcpp"               
#> [70] "RcppEigen"           "rematch2"            "reshape"            
#> [73] "reshape2"            "rlang"               "Rmpfr"              
#> [76] "rstudioapi"          "scales"              "splines"            
#> [79] "stats"               "statsExpressions"    "stringi"            
#> [82] "stringr"             "SuppDists"           "tibble"             
#> [85] "tidyr"               "tidyselect"          "tools"              
#> [88] "utf8"                "utils"               "vctrs"              
#> [91] "viridisLite"         "withr"               "WRS2"               
#> [94] "zeallot"

Dependency graph

library(deepdep)

plot_dependencies("ggstatsplot", depth = 3)

Heaviness of package dependencies

library(pkgndep)
x <- pkgndep("ggstatsplot")
plot(x)

Suggestions

If you find any bugs or have any suggestions/remarks, please file an issue on GitHub: https://github.com/IndrajeetPatil/ggstatsplot/issues